package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\B@([^\B ]+)`)
var str = []byte(`test @hello test`)
var substitution = []byte("<a href="profile.php?profile=$1">$0</a>")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}