using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\B@([^\B ]+)";
string substitution = @"<a href=""profile.php?profile=$1"">$0</a>";
string input = @"test @hello test";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}