// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\B@([^\B ]+)").unwrap();
let string = "test @hello test";
let substitution = "<a href=\"profile.php?profile=$1\">$0</a>";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}