$re = '/\B@([^\B ]+)/';
$str = 'test @hello test';
$subst = "<a href=\"profile.php?profile=$1\">$0</a>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;