use strict;
my $str = 'test @hello test';
my $regex = qr/\B@([^\B ]+)/p;
my $subst = '<a href="profile.php?profile=$1">$0</a>';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";