re = /\B@([^\B ]+)/
str = 'test @hello test'
subst = '<a href="profile.php?profile=$1">$0</a>'
result = str.sub(re, subst)
# Print the result of the substitution
puts result