# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:\\/\*)(.*?)(?:\*\\/))//gs;t' <<< "foo/*comment*/bar
fo/*comment*/obar
fooba/*comment*/r"