$re = '/((?:\/\*)(.*?)(?:\*\/))/s';
$str = 'foo/*comment*/bar
fo/*comment*/obar
fooba/*comment*/r';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;