using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\/\*)(.*?)(?:\*\/))";
string substitution = @"";
string input = @"foo/*comment*/bar
fo/*comment*/obar
fooba/*comment*/r";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}