use strict;
my $str = 'foo/*comment*/bar
fo/*comment*/obar
fooba/*comment*/r';
my $regex = qr/((?:\/\*)(.*?)(?:\*\/))/sp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";