re = /((?:\/\*)(.*?)(?:\*\/))/
str = 'foo/*comment*/bar
fo/*comment*/obar
fooba/*comment*/r'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result