package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)((?:\/\*)(.*?)(?:\*\/))`)
var str = `foo/*comment*/bar
fo/*comment*/obar
fooba/*comment*/r`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}