const regex = /((?:\/\*)(.*?)(?:\*\/))/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:\\\/\\*)(.*?)(?:\\*\\\/))', 'gs')
const str = `foo/*comment*/bar
fo/*comment*/obar
fooba/*comment*/r`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);