#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)((?:\/\*)(.*?)(?:\*\/))"
Local $sString = "foo/*comment*/bar" & @CRLF & _
"fo/*comment*/obar" & @CRLF & _
"fooba/*comment*/r"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)