#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[{2}([^\W]+)\]{2}\n([^[]+)"
Local $sString = "[[section_abc]]" & @CRLF & _
"<div>" & @CRLF & _
"several lines of html ..." & @CRLF & _
"sdsdoisdoisdosodisodi" & @CRLF & _
"<more><a href=""></a>" & @CRLF & _
"</div>" & @CRLF & _
"[[/section_abc]]" & @CRLF & _
"" & @CRLF & _
"][ [] ][ ]] [[ " & @CRLF & _
"Example 1" & @CRLF & _
"[[ ]] [][] [][" & @CRLF & _
"" & @CRLF & _
"[[section_opq]]" & @CRLF & _
"<div>" & @CRLF & _
"several lines of html ..." & @CRLF & _
"<more><a href=""></a>" & @CRLF & _
"</div>" & @CRLF & _
"[[/section_opq]]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")