import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[{2}([^\\W]+)\\]{2}\\n([^[]+)";
final String string = "[[section_abc]]\n"
+ "<div>\n"
+ "several lines of html ...\n"
+ "sdsdoisdoisdosodisodi\n"
+ "<more><a href=\"\"></a>\n"
+ "</div>\n"
+ "[[/section_abc]]\n\n"
+ "][ [] ][ ]] [[ \n"
+ "Example 1\n"
+ "[[ ]] [][] [][\n\n"
+ "[[section_opq]]\n"
+ "<div>\n"
+ "several lines of html ...\n"
+ "<more><a href=\"\"></a>\n"
+ "</div>\n"
+ "[[/section_opq]]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}