package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[{2}([^\W]+)\]{2}\n([^[]+)`)
var str = `[[section_abc]]
<div>
several lines of html ...
sdsdoisdoisdosodisodi
<more><a href=""></a>
</div>
[[/section_abc]]
][ [] ][ ]] [[
Example 1
[[ ]] [][] [][
[[section_opq]]
<div>
several lines of html ...
<more><a href=""></a>
</div>
[[/section_opq]]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}