// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[{2}([^\W]+)\]{2}\n([^[]+)").unwrap();
let string = "[[section_abc]]
<div>
several lines of html ...
sdsdoisdoisdosodisodi
<more><a href=\"\"></a>
</div>
[[/section_abc]]
][ [] ][ ]] [[
Example 1
[[ ]] [][] [][
[[section_opq]]
<div>
several lines of html ...
<more><a href=\"\"></a>
</div>
[[/section_opq]]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}