re = /\[{2}([^\W]+)\]{2}\n([^[]+)/
str = '[[section_abc]]
<div>
several lines of html ...
sdsdoisdoisdosodisodi
<more><a href=""></a>
</div>
[[/section_abc]]
][ [] ][ ]] [[
Example 1
[[ ]] [][] [][
[[section_opq]]
<div>
several lines of html ...
<more><a href=""></a>
</div>
[[/section_opq]]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end