using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[{2}([^\W]+)\]{2}\n([^[]+)";
string input = @"[[section_abc]]
<div>
several lines of html ...
sdsdoisdoisdosodisodi
<more><a href=""></a>
</div>
[[/section_abc]]
][ [] ][ ]] [[
Example 1
[[ ]] [][] [][
[[section_opq]]
<div>
several lines of html ...
<more><a href=""></a>
</div>
[[/section_opq]]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}