import Foundation
let pattern = #"\[{2}([^\W]+)\]{2}\n([^[]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[[section_abc]]
<div>
several lines of html ...
sdsdoisdoisdosodisodi
<more><a href=""></a>
</div>
[[/section_abc]]
][ [] ][ ]] [[
Example 1
[[ ]] [][] [][
[[section_opq]]
<div>
several lines of html ...
<more><a href=""></a>
</div>
[[/section_opq]]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)