# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\\/.*?\\/.*?\\/).*?\\//\1p13\//;t' <<< "/qw/ty/s11/dc3/124"