re = /(\/.*?\/.*?\/).*?\//
str = '/qw/ty/s11/dc3/124'
subst = '\\1p13/'
result = str.sub(re, subst)
# Print the result of the substitution
puts result