// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\/.*?\/.*?\/).*?\/").unwrap();
let string = "/qw/ty/s11/dc3/124";
let substitution = "\\1p13/";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}