use strict;
my $str = '/qw/ty/s11/dc3/124';
my $regex = qr/(\/.*?\/.*?\/).*?\//p;
my $subst = '\\1p13/';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";