import Foundation
let pattern = #"(\/.*?\/.*?\/).*?\/"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"/qw/ty/s11/dc3/124"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1p13/"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}