# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"([a-zA-Z]+)\s+([a-zA-Z]*)":/$1_$2/gm;t' <<< "Finds: \"First Name\":"