use strict;
my $str = 'Finds: "First Name":';
my $regex = qr/"([a-zA-Z]+)\s+([a-zA-Z]*)":/mp;
my $subst = '$1_$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";