import Foundation
let pattern = #""([a-zA-Z]+)\s+([a-zA-Z]*)":"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Finds: "First Name":"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1_$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)