const regex = /"([a-zA-Z]+)\s+([a-zA-Z]*)":/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"([a-zA-Z]+)\\s+([a-zA-Z]*)":', 'gm')
const str = `Finds: "First Name":`;
const subst = `$1_$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);