re = /"([a-zA-Z]+)\s+([a-zA-Z]*)":/m
str = 'Finds: "First Name":'
subst = '$1_$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result