$re = '/"([a-zA-Z]+)\s+([a-zA-Z]*)":/m';
$str = 'Finds: "First Name":';
$subst = "$1_$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;