# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(Grid\.Column=\"\d\")( )(Grid\.Row=\"\d\")/$3$2$1/gm;t' <<< "Grid.Column=\"1\" Grid.Row=\"2\"
Grid.Row=\"1\" Grid.Column=\"2\""