use strict;
my $str = 'Grid.Column="1" Grid.Row="2"
Grid.Row="1" Grid.Column="2"';
my $regex = qr/(Grid\.Column=\"\d\")( )(Grid\.Row=\"\d\")/mp;
my $subst = '$3$2$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";