import re
regex = re.compile(r"(Grid\.Column=\"\d\")( )(Grid\.Row=\"\d\")", flags=re.MULTILINE)
test_str = ("Grid.Column=\"1\" Grid.Row=\"2\"\n"
"Grid.Row=\"1\" Grid.Column=\"2\"")
subst = "$3$2$1"
result = regex.sub(subst, test_str)
if result:
print(result)