// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(Grid\.Column=\"\d\")( )(Grid\.Row=\"\d\")"#).unwrap();
let string = "Grid.Column=\"1\" Grid.Row=\"2\"
Grid.Row=\"1\" Grid.Column=\"2\"";
let substitution = "$3$2$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}