const regex = new RegExp('(Grid\\.Column=\\"\\d\\")( )(Grid\\.Row=\\"\\d\\")', 'gm')
const str = `Grid.Column="1" Grid.Row="2"
Grid.Row="1" Grid.Column="2"`;
const subst = `$3$2$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);