using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<tr.*?>(<td.*?>|</td>|\s)*</tr>";
string input = @"<tr>
<td collspan=""5""> <b>Какой-то текст</b>
</td>
</tr>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}