import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<tr.*?>(<td.*?>|</td>|\\s)*</tr>";
final String string = "<tr>\n"
+ "<td collspan=\"5\"> <b>Какой-то текст</b>\n"
+ "</td>\n"
+ "</tr>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}