package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<tr.*?>(<td.*?>|</td>|\s)*</tr>`)
var str = `<tr>
<td collspan="5"> <b>Какой-то текст</b>
</td>
</tr>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}