import re
regex = re.compile(r"<tr.*?>(<td.*?>|</td>|\s)*</tr>")
test_str = ("<tr>\n"
"<td collspan=\"5\"> <b>Какой-то текст</b>\n"
"</td>\n"
"</tr>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")