import Foundation
let pattern = #"<tr.*?>(<td.*?>|</td>|\s)*</tr>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<tr>
<td collspan="5"> <b>Какой-то текст</b>
</td>
</tr>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}