$re = '@<tr.*?>(<td.*?>|</td>|\s)*</tr>@';
$str = '<tr>
<td collspan="5"> <b>Какой-то текст</b>
</td>
</tr>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);