package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Received:\s+(?P<myfield>.+\;[\r|\n].+)`)
var str = `Received: by 10.52.65.232 with SMTP id a8csp4016332vdt;
Fri, 2 Jan 2015 12:46:51 -0800 (PST)
X-Received: by 10.68.241.35 with SMTP id wf3mr127732074pbc.22.1420231611043;
Fri, 02 Jan 2015 12:46:51 -0800 (PST)
Return-Path: `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}