re = /Received:\s+(?P<myfield>.+\;[\r|\n].+)/
str = 'Received: by 10.52.65.232 with SMTP id a8csp4016332vdt;
Fri, 2 Jan 2015 12:46:51 -0800 (PST)
X-Received: by 10.68.241.35 with SMTP id wf3mr127732074pbc.22.1420231611043;
Fri, 02 Jan 2015 12:46:51 -0800 (PST)
Return-Path: '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end