import re
regex = re.compile(r"Received:\s+(?P<myfield>.+\;[\r|\n].+)")
test_str = ("Received: by 10.52.65.232 with SMTP id a8csp4016332vdt;\n"
"Fri, 2 Jan 2015 12:46:51 -0800 (PST)\n"
"X-Received: by 10.68.241.35 with SMTP id wf3mr127732074pbc.22.1420231611043;\n"
"Fri, 02 Jan 2015 12:46:51 -0800 (PST)\n"
"Return-Path: ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")