import Foundation
let pattern = #"Received:\s+(?P<myfield>.+\;[\r|\n].+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Received: by 10.52.65.232 with SMTP id a8csp4016332vdt;
Fri, 2 Jan 2015 12:46:51 -0800 (PST)
X-Received: by 10.68.241.35 with SMTP id wf3mr127732074pbc.22.1420231611043;
Fri, 02 Jan 2015 12:46:51 -0800 (PST)
Return-Path:
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)