// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"Received:\s+(?P<myfield>.+\;[\r|\n].+)").unwrap();
let string = "Received: by 10.52.65.232 with SMTP id a8csp4016332vdt;
Fri, 2 Jan 2015 12:46:51 -0800 (PST)
X-Received: by 10.68.241.35 with SMTP id wf3mr127732074pbc.22.1420231611043;
Fri, 02 Jan 2015 12:46:51 -0800 (PST)
Return-Path: ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}