import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Received:\\s+(?P<myfield>.+\\;[\\r|\\n].+)";
final String string = "Received: by 10.52.65.232 with SMTP id a8csp4016332vdt;\n"
+ "Fri, 2 Jan 2015 12:46:51 -0800 (PST)\n"
+ "X-Received: by 10.68.241.35 with SMTP id wf3mr127732074pbc.22.1420231611043;\n"
+ "Fri, 02 Jan 2015 12:46:51 -0800 (PST)\n"
+ "Return-Path: ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}