use strict;
my $str = 'Received: by 10.52.65.232 with SMTP id a8csp4016332vdt;
Fri, 2 Jan 2015 12:46:51 -0800 (PST)
X-Received: by 10.68.241.35 with SMTP id wf3mr127732074pbc.22.1420231611043;
Fri, 02 Jan 2015 12:46:51 -0800 (PST)
Return-Path: ';
my $regex = qr/Received:\s+(?P<myfield>.+\;[\r|\n].+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}